aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNeale Ranns <neale.ranns@cisco.com>2017-10-16 04:20:13 -0700
committerDamjan Marion <dmarion.lists@gmail.com>2017-11-01 09:28:06 +0000
commit812ed39f9da336310e815c361ab5a9f118657d94 (patch)
tree9d8cddc917acbb65b3dc401d880d5eb2a7f392c6 /src/Makefile.am
parent14edd97c20735ffd1c24000a7df78e154ac61478 (diff)
VPP Object Model (VOM)
The VOM is a C++ library for use by clients/agents of VPP for programming state. It uses the binary APIs to do so. Various other common client side functions are also provided. Please see om.hpp for a more detailed description. Change-Id: Ib756bfe99817093815a9e26ccf464aa5583fc523 Signed-off-by: Neale Ranns <neale.ranns@cisco.com> Co-authored-by: Mohsin Kazmi <sykazmi@cisco.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c1b6b0e9d89..7b6818f2098 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,6 +20,7 @@ ACLOCAL_AMFLAGS = -I m4
AM_LIBTOOLFLAGS = --quiet
AM_CFLAGS = -Wall
+AM_CXXFLAGS = -Wall -std=gnu++11
SUBDIRS = .
SUFFIXES = .api.h .api .api.json
@@ -82,6 +83,7 @@ SUBDIRS += vpp-api/java
endif
SUBDIRS += vpp-api/vapi
+SUBDIRS += vpp-api/vom
###############################################################################
# API