aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorAmir Zeidner <amirzei@mellanox.com>2018-03-05 14:32:22 +0200
committerDamjan Marion <dmarion.lists@gmail.com>2018-03-05 18:40:41 +0000
commit0e7fe4fddb493350cf78c8126e9cc93d55490c42 (patch)
tree2a6c639e48a91c76a9d93b11689fdf367b5c082c /src/configure.ac
parentf7b7fa53b7eaec81d8c00c1023fb7d01f1f9761f (diff)
Set DPDK_MLX4_PMD and DPDK_MLX5_PMD compile with default dlopen links
dlopen linkage allow more transparent use for Mellanox nics. Mellanox shared library librte_pmd_mlx5/4_glue.so* placed in LD_LIBRARY_PATH At run time Mellanox code will be loaded only when Mellanox nics explicty used. i.e if VPP is used with other vendor Mellanox code is not loaded. Change-Id: Ib05bdbfc4cbb6e447c67186c98361f9c5b447140 Signed-off-by: Amir Zeidner <amirzei@mellanox.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 37e1bb2f626..857bd01521a 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -271,28 +271,6 @@ AM_CONDITIONAL(WITH_AESNI_MB_LIB, test "$with_aesni_mb_lib" = "yes")
m4_append([list_of_with], [isa_l_crypto_lib], [, ])
AM_CONDITIONAL(WITH_ISA_L_CRYPTO_LIB, test "$with_isa_l_crypto_lib" = "yes")
-
-with_ibverbs_lib=no
-DPDK_IS_PMD_ENABLED(LIBRTE_MLX4_PMD, dpdk_mlx4_pmd)
-AM_COND_IF([WITH_DPDK_MLX4_PMD],
-[
- AC_CHECK_LIB([ibverbs], [ibv_fork_init],
- [with_ibverbs_lib=yes],
- [AC_MSG_ERROR([ibverbs library not found])])
-])
-
-DPDK_IS_PMD_ENABLED(LIBRTE_MLX5_PMD, dpdk_mlx5_pmd)
-AM_COND_IF([WITH_DPDK_MLX5_PMD],
-[
- AC_CHECK_LIB([ibverbs], [ibv_fork_init],
- [with_ibverbs_lib=yes],
- [AC_MSG_ERROR([ibverbs library not found])])
-])
-
-m4_append([list_of_with], [ibverbs_lib], [, ])
-AM_CONDITIONAL(WITH_IBVERBS_LIB, test "$with_ibverbs_lib" = "yes")
-
-
AM_COND_IF([ENABLE_G2],
[
PKG_CHECK_MODULES(g2, gtk+-2.0)