aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2018-02-21 12:07:41 -0800
committerDave Barach <openvpp@barachs.net>2018-03-02 12:54:31 +0000
commit371ca50a74a9c4f1b74c4c1b65c6fdec610fcfc3 (patch)
tree947e800faa7846223bdf8fb73429c657ddaf5805 /src/configure.ac
parent9e6356962a0cbb84f7ea9056b954d65aaa231a61 (diff)
session: first approximation implementation of tls
It consists of two main parts. First, add an application transport type whereby applications can offer transport to other applications. For instance, a tls app can offer transport services to other applications. And second, a tls transport app that leverages the mbedtls library for tls protocol implementation. Change-Id: I616996c6e6539a9e2368fab8a1ac874d7c5d9838 Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index c213454dbda..37e1bb2f626 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -137,6 +137,7 @@ DISABLE_ARG(vom, [Disable VPP object model bindings])
# --without-X
WITHOUT_ARG(libssl, [Disable libssl])
WITHOUT_ARG(apicli, [Disable binary api CLI])
+WITHOUT_ARG(mbedtls, [Disable mbedtls])
AC_ARG_WITH(unix,
AC_HELP_STRING([--with-unix],[Compile unix version of clib]),
@@ -196,6 +197,7 @@ AC_SUBST(APICLI, [-DVPP_API_TEST_BUILTIN=${n_with_apicli}])
AC_DEFINE_UNQUOTED(DPDK_SHARED_LIB, [${n_enable_dpdk_shared}])
AC_DEFINE_UNQUOTED(WITH_LIBSSL, [${n_with_libssl}])
+AC_DEFINE_UNQUOTED(WITH_MBEDTLS, [${n_with_mbedtls}])
# Silence following noise:
@@ -307,6 +309,15 @@ AM_COND_IF([ENABLE_MARVELL_PLUGIN],
])
])
+AM_COND_IF([WITH_MBEDTLS],
+[
+ AC_CHECK_HEADERS([mbedtls/ssl.h], [],
+ [
+ AC_MSG_WARN([mbedtls headers not found. TLS app disabled])
+ AM_CONDITIONAL(WITH_MBEDTLS, false)
+ ], [])
+])
+
AC_PATH_PROG([VPPAPIGEN], [vppapigen], [no])
if test "$VPPAPIGEN" = "no"; then
VPPAPIGEN=\$\(top_srcdir\)/tools/vppapigen/vppapigen