aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2017-11-17 09:46:41 +0100
committerSergio Gonzalez Monroy <sergio.gonzalez.monroy@intel.com>2017-11-20 11:41:22 +0000
commit45b485099d8bdf5985e9869bc8221852073f9369 (patch)
tree184c75dbe758a9606c16b89a56d4f62965c01663 /src/configure.ac
parent9d1d73a9010dcd0929dc932af1fd7117863f6758 (diff)
dpdk: add support for DPDK 17.11
Also remove DPDK 17.05 support. Change-Id: I4f96cb3f002cd90b12d800d6904f2364d7c4e270 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac36
1 files changed, 3 insertions, 33 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 56080e13b7b..d84a4817dd4 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -99,26 +99,6 @@ AC_DEFUN([DPDK_IS_PMD_ENABLED],
m4_append_uniq([list_of_with], [$2], [, ])
])
-AC_DEFUN([DETECT_DPDK_IS_1702_OR_1705],
-[
- AC_MSG_CHECKING([for RTE_VERSION 17.02/17.05 in rte_version.h])
- AC_TRY_RUN(
- [
- #include <rte_version.h>
- int main()
- {
- return ((RTE_VER_YEAR != 17) ||
- (RTE_VER_MONTH != 2 && RTE_VER_MONTH != 5));
- }
- ],
- [dpdk_is_1702_or_1705=yes]
- [AC_MSG_RESULT([yes])],
- [dpdk_is_1702_or_1705=no]
- [AC_MSG_RESULT([no])]
- )
- AM_CONDITIONAL(DPDK_IS_1702_OR_1705, test "$dpdk_is_1702_or_1705" = "yes")
-])
-
# Check if compiler supports specific flag
AC_DEFUN([CC_CHECK_FLAG],
[
@@ -262,8 +242,6 @@ with_isa_l_crypto_lib=no
DPDK_IS_PMD_ENABLED(LIBRTE_PMD_AESNI_MB, dpdk_aesni_mb_pmd)
DPDK_IS_PMD_ENABLED(LIBRTE_PMD_AESNI_GCM, dpdk_aesni_gcm_pmd)
-DETECT_DPDK_IS_1702_OR_1705()
-
AM_COND_IF([WITH_DPDK_AESNI_MB_PMD],
[
AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
@@ -273,17 +251,9 @@ AM_COND_IF([WITH_DPDK_AESNI_MB_PMD],
AM_COND_IF([WITH_DPDK_AESNI_GCM_PMD],
[
- AM_COND_IF([DPDK_IS_1702_OR_1705],
- [
- AC_CHECK_LIB([isal_crypto], [aesni_gcm128_init],
- [with_isa_l_crypto_lib=yes],
- [AC_MSG_ERROR([isal_crypto library not found])])
- ],
- [
- AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
- [with_aesni_mb_lib=yes],
- [AC_MSG_ERROR([IPSec_MB library not found])])
- ])
+ AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
+ [with_aesni_mb_lib=yes],
+ [AC_MSG_ERROR([IPSec_MB library not found])])
])
m4_append([list_of_with], [aesni_mb_lib], [, ])