aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2018-03-09 13:05:53 -0800
committerDave Barach <openvpp@barachs.net>2018-03-15 15:04:11 +0000
commit58d36f02b45c5af38b7df81fb7976129cad3e05b (patch)
tree84875ce654928ae2224b8c3a6a4d354f3fd13f7a /src/configure.ac
parent46c1c11ba08512a5e37392de1ddb306b139a5bcf (diff)
tls: add openssl engine
Change-Id: I6c215858d2c9c620787632b570950b15274c0df2 Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 74d5113b93e..26c2eb5510d 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -231,6 +231,7 @@ PLUGIN_ENABLED(srv6am)
PLUGIN_ENABLED(srv6as)
PLUGIN_ENABLED(stn)
PLUGIN_ENABLED(tlsmbedtls)
+PLUGIN_ENABLED(tlsopenssl)
###############################################################################
# Dependency checks
@@ -306,6 +307,12 @@ AM_COND_IF([ENABLE_TLSMBEDTLS_PLUGIN],
], [])
])
+AM_COND_IF([WITH_LIBSSL], [],
+[
+ AC_MSG_WARN([openssl not enabled. Disabling tlsopenssl plugin])
+ enable_tlsopenssl_plugin=no
+ AM_CONDITIONAL(ENABLE_TLSOPENSSL_PLUGIN, false)
+])
###############################################################################
# JAVA