aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorDamjan Marion <damjan.marion@gmail.com>2017-12-26 13:40:13 +0000
committerDamjan Marion <dmarion.lists@gmail.com>2018-01-15 16:36:09 +0000
commit92cdd72058a80d0b8b28c00495b3051a0390d545 (patch)
tree9d3743739f6cbd3e6e63c5c90a2f0cb7ee3b7fae /src/configure.ac
parentc5239ad59716a833a15523755b03418a47e02a5a (diff)
Marvell device plugin
Depends in musdk 17.10 [1], tested on MACCHIATObin [2] board. currently only coves PP2. musdk must be compiled with: ./configure --enable-bpool-dma=64 [1] https://github.com/MarvellEmbeddedProcessors/musdk-marvell [2] http://macchiatobin.net Change-Id: I0247a6b860b0a067c54190eae0bd3fe08de234ad Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index d2fd5814619..bfd59372084 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -217,6 +217,7 @@ PLUGIN_ENABLED(ioam)
PLUGIN_ENABLED(ixge)
PLUGIN_ENABLED(kubeproxy)
PLUGIN_ENABLED(lb)
+PLUGIN_ENABLED(marvell)
PLUGIN_ENABLED(memif)
PLUGIN_ENABLED(pppoe)
PLUGIN_ENABLED(sixrd)
@@ -291,6 +292,17 @@ AM_COND_IF([ENABLE_G2],
PKG_CHECK_MODULES(g2, gtk+-2.0)
])
+AM_COND_IF([ENABLE_MARVELL_PLUGIN],
+[
+ AC_CHECK_LIB( [musdk], [pp2_init],
+ [],
+ [
+ AC_MSG_WARN([Marvell MUSDK library with PP2 support not found. Plugin disabled.])
+ enable_marvell_plugin=no
+ AM_CONDITIONAL(ENABLE_MARVELL_PLUGIN, false)
+ ])
+])
+
# If cross-compiling, we need external vppapigen and we cannot continue without it
# For native builds, we just set dependency on vpppaigen binary in top_builddir
AM_COND_IF([CROSSCOMPILE],