aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2017-07-04 20:11:57 +0800
committerNeale Ranns <nranns@cisco.com>2017-08-09 07:41:11 +0000
commit62f9cdd82c52dc05cb89a742d21aba013ce526d4 (patch)
tree76fcde5125faf02ae21724598786e72acc568769 /src/configure.ac
parentf73d0e2ea6bf4e0dc9c69ec4f1d0c7b9b41d2fa3 (diff)
Add PPPoE Plugin
Supports 64K PPPoE sessions This plugin adds three graph nodes: 1) pppoe-input for PPPoE decapsulation 2) pppoe-encap for PPPoE encapsulation 3) pppoe-tap-dispatch for control plane process Below is the configuration to make PPPoE CP and DP work: vim /etc/vpp/startup.conf tuntap { enable ethernet name newtap } create pppoe tap tap-if-index 1 //Configure it after a subscriber's PPPoE discovery and PPP link establishment succeeds: create pppoe session client-ip 100.1.2.1 session-id 1 client-mac 00:11:01:00:00:01 show pppoe fib show pppoe session Change-Id: I73e724b6bf7c3e4181a9914c5752da1fa72d7e60 Signed-off-by: Hongjun Ni <hongjun.ni@intel.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index cb00d0bdb2c..7a038c2e49d 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -167,6 +167,7 @@ PLUGIN_ENABLED(ioam)
PLUGIN_ENABLED(ixge)
PLUGIN_ENABLED(lb)
PLUGIN_ENABLED(memif)
+PLUGIN_ENABLED(pppoe)
PLUGIN_ENABLED(sixrd)
PLUGIN_ENABLED(snat)