summaryrefslogtreecommitdiffstats
path: root/src/plugins/adl/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2020-07-14 18:30:05 -0400
committerDamjan Marion <dmarion@me.com>2020-07-16 21:39:23 +0000
commitac0326fc5ae7ac4a8126bbc2f496a92fcfe4755e (patch)
tree3bb8d7fac43b165ccd6dd106b597fd733e5b28b8 /src/plugins/adl/CMakeLists.txt
parent9a0f2a5e7f678de58807fd49d47deec367656715 (diff)
adl: move allow/deny list function to plugin
Provide binary API compatibility support for the "cop" APIs until vpp 21.01. Change the deprecation date in map.api to vpp 21.01. Type: refactor Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I0e60d96de4ae9ae4448f134cf257934126f3b760
Diffstat (limited to 'src/plugins/adl/CMakeLists.txt')
-rw-r--r--src/plugins/adl/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/plugins/adl/CMakeLists.txt b/src/plugins/adl/CMakeLists.txt
new file mode 100644
index 00000000000..a1a61be4a5c
--- /dev/null
+++ b/src/plugins/adl/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Copyright (c) 2020 Cisco Systems and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(adl
+ SOURCES
+ adl_api.c
+ adl.c
+ adl.h
+ ip4_allowlist.c
+ ip6_allowlist.c
+ node.c
+
+ MULTIARCH_SOURCES
+ node.c
+
+ API_FILES
+ adl.api
+
+ API_TEST_SOURCES
+ adl_test.c
+)