summaryrefslogtreecommitdiffstats
path: root/src/plugins/af_packet/CMakeLists.txt
diff options
context:
space:
mode:
authorMohsin Kazmi <sykazmi@cisco.com>2022-12-14 13:10:29 +0000
committerDave Wallace <dwallacelf@gmail.com>2022-12-21 18:33:51 +0000
commitbca76580b17bbb6227f48b9ea4a5858802656962 (patch)
treeba8df625df7a4de1ea5fd970493d7cda74deedb7 /src/plugins/af_packet/CMakeLists.txt
parentbb98aac4223f506ec18109f9836daa6ef0d61180 (diff)
af_packet: move to plugin
Type: improvement Signed-off-by: Mohsin Kazmi <sykazmi@cisco.com> Change-Id: I3ec857adb3a9e8a778072a202a4d23f4101e83b2
Diffstat (limited to 'src/plugins/af_packet/CMakeLists.txt')
-rw-r--r--src/plugins/af_packet/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/plugins/af_packet/CMakeLists.txt b/src/plugins/af_packet/CMakeLists.txt
new file mode 100644
index 00000000000..4b79615cae7
--- /dev/null
+++ b/src/plugins/af_packet/CMakeLists.txt
@@ -0,0 +1,36 @@
+# SPDX-License-Identifier: Apache-2.0
+# Copyright (c) 2022 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(af_packet
+ SOURCES
+ plugin.c
+ af_packet.c
+ device.c
+ node.c
+ cli.c
+ af_packet_api.c
+
+ MULTIARCH_SOURCES
+ node.c
+ device.c
+
+ INSTALL_HEADERS
+ af_packet.h
+
+ API_FILES
+ af_packet.api
+
+ # API_TEST_SOURCES
+ #af_packet_test_api.c
+)