summaryrefslogtreecommitdiffstats
path: root/src/plugins/builtinurl/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-09-17 09:47:35 -0400
committerFlorin Coras <florin.coras@gmail.com>2019-09-18 14:26:59 +0000
commit43765e2b4eaa8e1f2a5f1562414e04962c777ff3 (patch)
treee5a18e7ba42c4c7fb962d034e22a79d9beb89288 /src/plugins/builtinurl/CMakeLists.txt
parent4bf849043d6ffc1d3d43e65f381e310f425d01f7 (diff)
builtinurl: initial working attempt
Note that the builtin URLs are disabled by default. To activate, "builtinurl enable" or use the builtinurl_enable API. See .../extras/http/sample.md for some Hugo-friendly .md w/ embedded Javascript that accesses the builtin URLs. Type: feature Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I6d82d9292c41d6d2d90be73ba8a1a043fb20c986
Diffstat (limited to 'src/plugins/builtinurl/CMakeLists.txt')
-rw-r--r--src/plugins/builtinurl/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/plugins/builtinurl/CMakeLists.txt b/src/plugins/builtinurl/CMakeLists.txt
new file mode 100644
index 00000000000..e866f1174f1
--- /dev/null
+++ b/src/plugins/builtinurl/CMakeLists.txt
@@ -0,0 +1,30 @@
+
+# Copyright (c) <current-year> <your-organization>
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(builtinurl
+ SOURCES
+ builtins.c
+ builtinurl.c
+ builtinurl.h
+
+ API_FILES
+ builtinurl.api
+
+ INSTALL_HEADERS
+ builtinurl_all_api_h.h
+ builtinurl_msg_enum.h
+
+ API_TEST_SOURCES
+ builtinurl_test.c
+)