summaryrefslogtreecommitdiffstats
path: root/src/plugins/crypto_native/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2020-01-28 09:55:25 +0100
committerDamjan Marion <dmarion@me.com>2020-01-28 10:24:18 +0000
commit7d08e39a87f5805d1ef764aa0fd986490fb4f7bb (patch)
tree27d838a8f5681dea82d2661c2d70526af9d0fef0 /src/plugins/crypto_native/CMakeLists.txt
parent0d4a61216c2329eec5167d0411481431037ac5c1 (diff)
crypto-native: rename crypto_ia32 to crypto_native
Type: refactor Change-Id: I9f21b3bf669ff913ff50afe5459cf52ff987e701 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/plugins/crypto_native/CMakeLists.txt')
-rw-r--r--src/plugins/crypto_native/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/plugins/crypto_native/CMakeLists.txt b/src/plugins/crypto_native/CMakeLists.txt
new file mode 100644
index 00000000000..cd701ec7d55
--- /dev/null
+++ b/src/plugins/crypto_native/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+if(NOT CMAKE_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
+ return()
+endif()
+
+add_vpp_plugin(crypto_native SOURCES main.c)
+
+list(APPEND VARIANTS "sse42\;-march=silvermont")
+list(APPEND VARIANTS "avx2\;-march=core-avx2")
+if(compiler_flag_march_skylake_avx512)
+ list(APPEND VARIANTS "avx512\;-march=skylake-avx512")
+endif()
+if(compiler_flag_march_icelake_client)
+ list(APPEND VARIANTS "vaesni\;-march=icelake-client")
+endif()
+
+foreach(VARIANT ${VARIANTS})
+ list(GET VARIANT 0 v)
+ list(GET VARIANT 1 f)
+ set(l crypto_native_${v})
+ add_library(${l} OBJECT aes_cbc.c aes_gcm.c)
+ set_target_properties(${l} PROPERTIES POSITION_INDEPENDENT_CODE ON)
+ target_compile_options(${l} PUBLIC ${f} -Wall -fno-common -maes)
+ target_sources(crypto_native_plugin PRIVATE $<TARGET_OBJECTS:${l}>)
+endforeach()