summaryrefslogtreecommitdiffstats
path: root/src/plugins/ct6/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-03-06 11:14:03 -0500
committerFlorin Coras <florin.coras@gmail.com>2019-03-06 17:19:22 +0000
commita55df1081762b4e40698ef7d9196551851be646a (patch)
treeeb1867e1de1fc78d18da9067d04423dfdb199cd1 /src/plugins/ct6/CMakeLists.txt
parente275bed64d12009726fcf43943f1684195cd1e5d (diff)
ipv6 connection tracking plugin
A security feature: drop unsolicited global unicast traffic. Change-Id: I421da7d52e08b7acf40c62a1f6e2a6caac349e7e Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'src/plugins/ct6/CMakeLists.txt')
-rw-r--r--src/plugins/ct6/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/plugins/ct6/CMakeLists.txt b/src/plugins/ct6/CMakeLists.txt
new file mode 100644
index 00000000000..069b33ad2d0
--- /dev/null
+++ b/src/plugins/ct6/CMakeLists.txt
@@ -0,0 +1,35 @@
+
+# Copyright (c) <current-year> <your-organization>
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(ct6
+ SOURCES
+ ct6.c
+ ct6_in2out.c
+ ct6_out2in.c
+ ct6.h
+
+ MULTIARCH_SOURCES
+ ct6_in2out.c
+ ct6_out2in.c
+
+ API_FILES
+ ct6.api
+
+ INSTALL_HEADERS
+ ct6_all_api_h.h
+ ct6_msg_enum.h
+
+ API_TEST_SOURCES
+ ct6_test.c
+)