summaryrefslogtreecommitdiffstats
path: root/src/plugins/dns/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-08-23 10:53:01 -0400
committerDave Barach <dave@barachs.net>2019-08-23 10:54:24 -0400
commit46441cb9cde2044c4e3e743d69418cecc897a63a (patch)
tree2b280cf8de88f53397d22cce9693eb23f7af2a02 /src/plugins/dns/CMakeLists.txt
parent1c586de48cc76fc6eac50f5d87003e2a80aa43e7 (diff)
dns: cherry-pick 21444, 21468 from master
Type: refactor Ticket: VPP-1752 Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: Ieaec721056531ba0c70538c9bf97769a0e80aefd
Diffstat (limited to 'src/plugins/dns/CMakeLists.txt')
-rw-r--r--src/plugins/dns/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/plugins/dns/CMakeLists.txt b/src/plugins/dns/CMakeLists.txt
new file mode 100644
index 00000000000..5d1ac8628db
--- /dev/null
+++ b/src/plugins/dns/CMakeLists.txt
@@ -0,0 +1,33 @@
+
+# Copyright (c) <current-year> <your-organization>
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(dns
+ SOURCES
+ dns.c
+ dns.h
+ request_node.c
+ reply_node.c
+ resolver_process.c
+
+ API_FILES
+ dns.api
+
+ INSTALL_HEADERS
+ dns_all_api_h.h
+ dns_msg_enum.h
+ dns_packet.h
+
+ API_TEST_SOURCES
+ dns_test.c
+)