aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/geneve/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2020-09-18 07:35:06 +0000
committerOle Tr�an <otroan@employees.org>2020-09-21 17:04:13 +0000
commit3a6adc52fe4cad83883c00ad47aefdfb995fb441 (patch)
treeedea9964987a211545d538c8641696a02e4aa3ad /src/plugins/geneve/CMakeLists.txt
parent6810a77da36c6750938800314c15e840ee2a8c93 (diff)
geneve: Move to plugin
Type: refactor Change-Id: I613bf4d6517591351b212bfe6c8d93abf235f5dc Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/geneve/CMakeLists.txt')
-rw-r--r--src/plugins/geneve/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/plugins/geneve/CMakeLists.txt b/src/plugins/geneve/CMakeLists.txt
new file mode 100644
index 00000000000..43eb0172097
--- /dev/null
+++ b/src/plugins/geneve/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(geneve
+ SOURCES
+ geneve.c
+ encap.c
+ decap.c
+ geneve_api.c
+
+ MULTIARCH_SOURCES
+ encap.c
+ decap.c
+
+ API_FILES
+ geneve.api
+
+ INSTALL_HEADERS
+ geneve.h
+ geneve_packet.h
+ geneve_error.def
+
+ API_TEST_SOURCES
+ geneve_test.c
+)