summaryrefslogtreecommitdiffstats
path: root/src/plugins/hs_apps/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2019-06-25 12:55:15 -0700
committerDave Wallace <dwallacelf@gmail.com>2019-06-26 02:15:20 +0000
commit00dd74cee7ef8c1c5265daf01db13891ed68507f (patch)
tree6fc40cb4cbd01cc993d75fba81a8b86850b32274 /src/plugins/hs_apps/CMakeLists.txt
parent33cd4823d67bb30d39a4bd5af50449b072c6354a (diff)
hsa: move vcl test apps to hsa
Type: refactor Change-Id: I352975585c1091bfc5b85d7f8fe985f9059820a7 Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'src/plugins/hs_apps/CMakeLists.txt')
-rw-r--r--src/plugins/hs_apps/CMakeLists.txt37
1 files changed, 31 insertions, 6 deletions
diff --git a/src/plugins/hs_apps/CMakeLists.txt b/src/plugins/hs_apps/CMakeLists.txt
index e7885c3d1bf..bf1f49cfa42 100644
--- a/src/plugins/hs_apps/CMakeLists.txt
+++ b/src/plugins/hs_apps/CMakeLists.txt
@@ -11,6 +11,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+##############################################################################
+# vpp builtin hs apps
+##############################################################################
add_vpp_plugin(hs_apps
SOURCES
echo_client.c
@@ -20,24 +23,46 @@ add_vpp_plugin(hs_apps
proxy.c
)
-option(VPP_BUILD_SESSION_ECHO_APPS "Build session echo apps." ON)
-if(VPP_BUILD_SESSION_ECHO_APPS)
+##############################################################################
+# vpp external hs apps that use the "raw" session layer api
+##############################################################################
+option(VPP_BUILD_HS_SAPI_APPS "Build hs apps that use the session api." ON)
+if(VPP_BUILD_HS_SAPI_APPS)
add_vpp_executable(tcp_echo
- SOURCES tcp_echo.c
+ SOURCES sapi/tcp_echo.c
LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
DEPENDS api_headers
NO_INSTALL
)
add_vpp_executable(quic_echo
- SOURCES quic_echo.c
+ SOURCES sapi/quic_echo.c
LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
DEPENDS api_headers
NO_INSTALL
)
add_vpp_executable(udp_echo
- SOURCES udp_echo.c
+ SOURCES sapi/udp_echo.c
LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
DEPENDS api_headers
NO_INSTALL
)
-endif(VPP_BUILD_SESSION_ECHO_APPS)
+endif(VPP_BUILD_HS_SAPI_APPS)
+
+##############################################################################
+# vcl tests
+##############################################################################
+option(VPP_BUILD_VCL_TESTS "Build vcl tests." ON)
+if(VPP_BUILD_VCL_TESTS)
+ foreach(test
+ vcl_test_server
+ vcl_test_client
+ sock_test_server
+ sock_test_client
+ )
+ add_vpp_executable(${test}
+ SOURCES "vcl/${test}.c"
+ LINK_LIBRARIES vppcom pthread
+ NO_INSTALL
+ )
+ endforeach()
+endif(VPP_BUILD_VCL_TESTS)