summaryrefslogtreecommitdiffstats
path: root/src/plugins/hs_apps/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2022-02-10 20:58:21 -0800
committerDave Barach <openvpp@barachs.net>2022-02-13 23:34:51 +0000
commitcfcc42e2904fbc55175a9075c543d43131dc9090 (patch)
treeafa56b18d2777e125f5a73958b143e5e019afe62 /src/plugins/hs_apps/CMakeLists.txt
parent1b969c2f6a181d4f7cca542dad00e4feb1e45650 (diff)
hsa: add http throughput test server app
Can be used for throughput testing over http. For instance, start server: http tps #implicitly listens on port 80 Then, to test throughput with curl: curl <server_ip>/test_file_10g curl <server_ip>/test_file_123m Similarly, for https: http tps uri tls://<server_ip>/443 curl -k <server_ip>/test_file_1g Type: feature Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: I30ab7f0d94a7357b3f04546e4a3d3c410a733908
Diffstat (limited to 'src/plugins/hs_apps/CMakeLists.txt')
-rw-r--r--src/plugins/hs_apps/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/hs_apps/CMakeLists.txt b/src/plugins/hs_apps/CMakeLists.txt
index 701d1374c92..aec322a2f4f 100644
--- a/src/plugins/hs_apps/CMakeLists.txt
+++ b/src/plugins/hs_apps/CMakeLists.txt
@@ -20,6 +20,7 @@ add_vpp_plugin(hs_apps
echo_server.c
hs_apps.c
http_cli.c
+ http_tps.c
proxy.c
)