summaryrefslogtreecommitdiffstats
path: root/src/plugins/hsi/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2021-06-07 11:41:21 -0700
committerDave Barach <openvpp@barachs.net>2021-12-21 19:39:17 +0000
commit68501d369c65faa67b4afc5c528e7eb04c097fc4 (patch)
treebcbd6e5a079d03c403f7246a2ffef1ec7f503f9b /src/plugins/hsi/CMakeLists.txt
parent61e26be8eda5dce028e0079ed367fd781ae40353 (diff)
hsi: host stack intercept plugin
Enable selective punting of flows to host stack Type: feature Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: Ib31a3abfe3b21a2aa448bfacc4591fa5c840f935
Diffstat (limited to 'src/plugins/hsi/CMakeLists.txt')
-rw-r--r--src/plugins/hsi/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/plugins/hsi/CMakeLists.txt b/src/plugins/hsi/CMakeLists.txt
new file mode 100644
index 00000000000..629f5e3762c
--- /dev/null
+++ b/src/plugins/hsi/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Copyright (c) 2021 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(hsi
+ SOURCES
+ hsi.c
+)