summaryrefslogtreecommitdiffstats
path: root/src/plugins/http/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2022-01-24 12:47:50 -0800
committerDamjan Marion <dmarion@me.com>2022-01-26 16:54:46 +0000
commit1d88fb97bef7dbe998830ea1eb2f8519c6cc9e97 (patch)
tree39fd8552586a0a102aafe51e2fadd14390c3eebf /src/plugins/http/CMakeLists.txt
parentb1c9c048a26a1675311849b7d2595b74911a897f (diff)
http: generalize buffer implementation
And add support for passing of pointers Type: improvement Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: Ida3e5ae4ff7842366ae92a5f33c5e761355951a6
Diffstat (limited to 'src/plugins/http/CMakeLists.txt')
-rw-r--r--src/plugins/http/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/http/CMakeLists.txt b/src/plugins/http/CMakeLists.txt
index 9f5ce778739..d9cd84a3955 100644
--- a/src/plugins/http/CMakeLists.txt
+++ b/src/plugins/http/CMakeLists.txt
@@ -14,5 +14,6 @@
add_vpp_plugin(http
SOURCES
http.c
+ http_buffer.c
http_timer.c
)