summaryrefslogtreecommitdiffstats
path: root/src/plugins/http/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2022-01-13 11:59:44 -0800
committerFlorin Coras <fcoras@cisco.com>2022-01-20 00:39:21 -0800
commit0b65621d41619e242b136e78fecfb325c90ae0bc (patch)
tree300e7002f2eae2afb5c235e2fe96705e34a79dbe /src/plugins/http/CMakeLists.txt
parentb85de19145a01d3acdf326c3cfa4e94b585bb59f (diff)
http: add http protocol plugin
Basic HTTP/1.1 server side implementation. Type: feature Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: I06bddaf7f11e28db802b4cd7ef8160c78cb019b6
Diffstat (limited to 'src/plugins/http/CMakeLists.txt')
-rw-r--r--src/plugins/http/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/plugins/http/CMakeLists.txt b/src/plugins/http/CMakeLists.txt
new file mode 100644
index 00000000000..9f5ce778739
--- /dev/null
+++ b/src/plugins/http/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright (c) 2022 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(http
+ SOURCES
+ http.c
+ http_timer.c
+)