summaryrefslogtreecommitdiffstats
path: root/src/plugins/ipsecmb/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <florin.coras@gmail.com>2019-01-02 17:43:01 +0000
committerDave Barach <openvpp@barachs.net>2019-01-02 18:50:37 +0000
commit4a7cbcd06b3fa1f44366a606d5c148cce816503b (patch)
tree69875f8c2342ddf376770e0d55876fdc53fc4aa2 /src/plugins/ipsecmb/CMakeLists.txt
parentd9818dd68c162079f3ddb5443a78d0d91d55d0fe (diff)
Revert "add ipsecmb plugin"
This reverts commit be16020c5034bc69df25a8ecd7081aec9898d93c. The arm verify job actually failed but the result was overwritten by an x86 ubuntu retry. Change-Id: Idcae7691fc575053563b8ff8bcad661c15891668 Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'src/plugins/ipsecmb/CMakeLists.txt')
-rw-r--r--src/plugins/ipsecmb/CMakeLists.txt46
1 files changed, 0 insertions, 46 deletions
diff --git a/src/plugins/ipsecmb/CMakeLists.txt b/src/plugins/ipsecmb/CMakeLists.txt
deleted file mode 100644
index 38ecf644896..00000000000
--- a/src/plugins/ipsecmb/CMakeLists.txt
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright (c) 2018 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-find_path(IPSECMB_INCLUDE_DIR NAMES intel-ipsec-mb.h HINTS ${IPSECMB_INCLUDE_DIR_HINT})
-find_library(IPSECMB_LIB NAMES libIPSec_MB.a HINTS ${IPSECMB_LIB_DIR_HINT})
-
-if(IPSECMB_INCLUDE_DIR AND IPSECMB_LIB)
-
- get_filename_component(IPSECMB_LIB_DIR ${IPSECMB_LIB} DIRECTORY)
- set(IPSECMB_LINK_FLAGS "${IPSECMB_LINK_FLAGS} -L${IPSECMB_LIB_DIR} -Wl,--whole-archive ${IPSECMB_LIB} -Wl,--no-whole-archive")
- set(IPSECMB_LINK_FLAGS "${IPSECMB_LINK_FLAGS} -Wl,--exclude-libs,libIPSec_MB.a,-l:libIPSec_MB.a")
- include_directories(${IPSECMB_INCLUDE_DIR})
- add_vpp_plugin(ipsecmb
- SOURCES
- ipsecmb.c
- ah_encrypt.c
- ah_decrypt.c
- esp_encrypt.c
- esp_decrypt.c
-
- MULTIARCH_SOURCES
- ah_encrypt.c
- ah_decrypt.c
- esp_encrypt.c
- esp_decrypt.c
-
- LINK_FLAGS
- ${IPSECMB_LINK_FLAGS}
- )
-
- message(STATUS "Intel IPSecMB found: ${IPSECMB_INCLUDE_DIR}")
-else()
- message(STATUS "Intel IPSecMB not found")
-endif()
-
-