aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/lb/CMakeLists.txt
diff options
context:
space:
mode:
authorYulong Pei <yulong.pei@intel.com>2020-01-09 01:12:43 +0800
committerAndrew Yourtchenko <ayourtch@gmail.com>2020-08-12 15:59:46 +0000
commit3311a17e40500263f9a77de8a91b0572fc68ea4c (patch)
tree9aba96d2f6ca966effef896b438f980a1f53a0b5 /src/plugins/lb/CMakeLists.txt
parent4362672562f5b379361f147cbb7a9b72c3332c30 (diff)
lb: fix that lb_add_del_vip and lb_add_del_as api doesn't work correctly
Currently if user want to set ip4 address to the api, it must convert to ip6 format, e.g. user want to ip4 "90.1.2.1" but must convert to "::5A01:0201", it is not acceptable, this fix solved the issue. Ticket: FDIO-753 Type: fix Change-Id: I2ffa5a3d38400ee176cf601421074f71fc395f03 Signed-off-by: Yulong Pei <yulong.pei@intel.com> (cherry picked from commit db43bb6af78c33e47d29889b047cced4b11fe4d7)
Diffstat (limited to 'src/plugins/lb/CMakeLists.txt')
-rw-r--r--src/plugins/lb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/lb/CMakeLists.txt b/src/plugins/lb/CMakeLists.txt
index 69ca948a001..6fab329abfd 100644
--- a/src/plugins/lb/CMakeLists.txt
+++ b/src/plugins/lb/CMakeLists.txt
@@ -32,3 +32,4 @@ add_vpp_plugin(lb
lb_test.c
)
+target_link_libraries(lb_test_plugin vatclient)