aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/linux-cp/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <neale@graphiant.com>2021-02-05 09:04:35 +0000
committerOle Tr�an <otroan@employees.org>2022-01-28 10:46:31 +0000
commit616447c392311791e630a604a07a2c7e47dbb7d6 (patch)
tree7ee4bc904a141bcc8171b7f9e034f575b7904f2a /src/plugins/linux-cp/CMakeLists.txt
parent1fd912c8ddbc30d1cce153f16a11b5dcf1fa571e (diff)
linux-cp: Linux Control Plane Netlink Listener
Type: feature please see FEATURE.yaml for details. Signed-off-by: Neale Ranns <nranns@cisco.com> Signed-off-by: Matthew Smith <mgsmith@netgate.com> Signed-off-by: Jon Loeliger <jdl@netgate.com> Signed-off-by: Pim van Pelt <pim@ipng.nl> Signed-off-by: Neale Ranns <neale@graphiant.com> Change-Id: I6255fd9953d0b03e6b4fe75b67a6845a7c206f74 Signed-off-by: Pim van Pelt <pim@ipng.nl>
Diffstat (limited to 'src/plugins/linux-cp/CMakeLists.txt')
-rw-r--r--src/plugins/linux-cp/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/plugins/linux-cp/CMakeLists.txt b/src/plugins/linux-cp/CMakeLists.txt
index 5053207fff4..a30ece80501 100644
--- a/src/plugins/linux-cp/CMakeLists.txt
+++ b/src/plugins/linux-cp/CMakeLists.txt
@@ -60,3 +60,12 @@ add_vpp_plugin(linux_cp_unittest
LINK_LIBRARIES
lcp
)
+
+add_vpp_plugin(linux_nl
+ SOURCES
+ lcp_router.c
+ lcp_nl.c
+
+ LINK_LIBRARIES
+ lcp
+)