summaryrefslogtreecommitdiffstats
path: root/src/plugins/marvell/CMakeLists.txt
diff options
context:
space:
mode:
authorJianlin Lv <Jianlin.Lv@arm.com>2019-10-30 13:35:38 +0800
committerAndrew Yourtchenko <ayourtch@gmail.com>2019-11-07 13:32:36 +0000
commit1c3c9f0393e4bd3a5902efbc79cb9a4e6737bda2 (patch)
treef32b6a8449377e18bd95370039e28649a2992a05 /src/plugins/marvell/CMakeLists.txt
parent387123e675c222b52f720b6fd5ac0c7b3f016bcd (diff)
api: Add API support for PP2 plugin to stable/1908
Support create/delete interface with marvell PP2 API Type: feature Signed-off-by: Jianlin Lv <Jianlin.Lv@arm.com> Change-Id: I2a81024e0fcf2f389d39a5498167a752f8f807e5
Diffstat (limited to 'src/plugins/marvell/CMakeLists.txt')
-rw-r--r--src/plugins/marvell/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/plugins/marvell/CMakeLists.txt b/src/plugins/marvell/CMakeLists.txt
index 4e4b76886fa..a3fcee69050 100644
--- a/src/plugins/marvell/CMakeLists.txt
+++ b/src/plugins/marvell/CMakeLists.txt
@@ -29,6 +29,17 @@ if(MUSDK_INCLUDE_DIR AND MUSDK_LIB)
pp2/input.c
pp2/output.c
pp2/pp2.c
+ pp2/pp2_api.c
+
+ API_FILES
+ pp2/pp2.api
+
+ API_TEST_SOURCES
+ pp2/pp2_test.c
+
+ INSTALL_HEADERS
+ pp2/pp2_all_api_h.h
+ pp2/pp2_msg_enum.h
LINK_FLAGS
${MUSDK_LINK_FLAGS}