summaryrefslogtreecommitdiffstats
path: root/src/plugins/netmap/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Jones <thj@freebsd.org>2024-02-07 14:55:20 +0000
committerDamjan Marion <dmarion@0xa5.net>2024-05-14 07:15:12 +0000
commit16cc51b88a16c14002aebcff9943167b75d79a92 (patch)
tree244bff2f124150c0eccfe28680a2878bfc5b21c9 /src/plugins/netmap/CMakeLists.txt
parent2516b1ac73cd0dd13ceb10bb8e7824ebc683dc34 (diff)
netmap: Reinstate and update netmap plugin
Thet netmap plugin was moved to depreciated in commit 998b8fe. On FreeBSD netmap offers a natively supported kernel interface for userspace networking and enables VPP without the use of DPDK. Reinstate the netmap plugin and adapt it to the newer plugin interface. Type: improvement Change-Id: I113daa33a490f04cbb29909f9789fa66284ac80e Signed-off-by: Tom Jones <thj@freebsd.org>
Diffstat (limited to 'src/plugins/netmap/CMakeLists.txt')
-rw-r--r--src/plugins/netmap/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/plugins/netmap/CMakeLists.txt b/src/plugins/netmap/CMakeLists.txt
new file mode 100644
index 00000000000..d53a9e0911a
--- /dev/null
+++ b/src/plugins/netmap/CMakeLists.txt
@@ -0,0 +1,32 @@
+# SPDX-License-Identifier: Apache-2.0
+# Copyright (c) 2024 Tom Jones <thj@freebsd.org>
+#
+# This software was developed by Tom Jones <thj@freebsd.org> under sponsorship
+# from the FreeBSD Foundation.
+#
+
+if (NOT "${CMAKE_SYSTEM_NAME}" STREQUAL "FreeBSD")
+ message(WARNING "Netmap is only currently support on FreeBSD - netmap plugin disabled")
+ return()
+endif()
+
+add_vpp_plugin(netmap
+ SOURCES
+ plugin.c
+ netmap.c
+ node.c
+ device.c
+ cli.c
+ netmap_api.c
+
+ MULTIARCH_SOURCES
+ node.c
+ device.c
+
+ INSTALL_HEADERS
+ netmap.h
+ net_netmap.h
+
+ API_FILES
+ netmap.api
+)