summaryrefslogtreecommitdiffstats
path: root/src/plugins/oddbuf/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-09-04 12:09:32 -0400
committerDave Barach <openvpp@barachs.net>2019-09-07 01:26:58 +0000
commitc4abafd83df38051765352785b146277734701f4 (patch)
tree12633dc1337661d1c4d408df2d1bca67e1d940bc /src/plugins/oddbuf/CMakeLists.txt
parentb736e75d5bb2d132fb00c35b6aabaa52e5f624ad (diff)
ip: fix udp/tcp checksum corner cases
When checksumming chained buffers with odd lengths: insert a NULL byte, or the calculation fails. Type: fix Signed-off-by: Dave Barach <dave@barachs.net> Signed-off-by: John Lo <loj@cisco.com> Change-Id: I380f7c42897bdb28c8c29aa1c4cdaaa849cc9ecc
Diffstat (limited to 'src/plugins/oddbuf/CMakeLists.txt')
-rw-r--r--src/plugins/oddbuf/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/plugins/oddbuf/CMakeLists.txt b/src/plugins/oddbuf/CMakeLists.txt
new file mode 100644
index 00000000000..06f8e6f7e61
--- /dev/null
+++ b/src/plugins/oddbuf/CMakeLists.txt
@@ -0,0 +1,33 @@
+
+# Copyright (c) <current-year> <your-organization>
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(oddbuf
+ SOURCES
+ oddbuf.c
+ node.c
+ oddbuf.h
+
+ MULTIARCH_SOURCES
+ node.c
+
+ API_FILES
+ oddbuf.api
+
+ INSTALL_HEADERS
+ oddbuf_all_api_h.h
+ oddbuf_msg_enum.h
+
+ API_TEST_SOURCES
+ oddbuf_test.c
+)