summaryrefslogtreecommitdiffstats
path: root/src/plugins/osi/CMakeLists.txt
diff options
context:
space:
mode:
authorHadi Rayan Al-Sandid <halsandi@cisco.com>2024-08-01 17:10:54 +0200
committerBeno�t Ganne <bganne@cisco.com>2024-08-22 08:00:52 +0000
commit8629336fa502b5859ed46bcc1976c824470092b3 (patch)
tree72c5757fba8d7009111a24cd6f814cf13b386bec /src/plugins/osi/CMakeLists.txt
parent85ce93160fa71c5e6fb9140704c07e6d8989889d (diff)
misc: move osi to plugin
Type: refactor This patch moves osi into a plugin, and also modifies the init functions of llc and snap to preserve init order dependency (llc_init --> osi_init --> snap_init). While the initial intent was to move osi/llc/snap together into a single plugin, there exists a dependency on llc in vnet/ethernet, which would require further refactoring and testing work. Change-Id: Ic0eff030ee29c8d316c0e0fe13931451aa193527 Signed-off-by: Hadi Rayan Al-Sandid <halsandi@cisco.com>
Diffstat (limited to 'src/plugins/osi/CMakeLists.txt')
-rw-r--r--src/plugins/osi/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/plugins/osi/CMakeLists.txt b/src/plugins/osi/CMakeLists.txt
new file mode 100644
index 00000000000..8ab014770ea
--- /dev/null
+++ b/src/plugins/osi/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright (c) 2023 Cisco and/or its affiliates
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(osi
+
+ SOURCES
+ osi.c
+ node.c
+ pg.c
+ plugin.c
+
+ INSTALL_HEADERS
+ osi.h
+)