summaryrefslogtreecommitdiffstats
path: root/src/plugins/perfmon/CMakeLists.txt
diff options
context:
space:
mode:
authorRay Kinsella <mdr@ashroe.eu>2021-06-09 11:35:26 +0100
committerDamjan Marion <dmarion@me.com>2021-09-08 14:30:03 +0000
commit710bdef43c2bfe6a6fd208edd080c75f06c5dfb7 (patch)
treeb5cd741b43ec616818a1f0607b8c6008773139a1 /src/plugins/perfmon/CMakeLists.txt
parentc3cb2075deef7cd35401f9d2f00f3aeb23ed16d5 (diff)
perfmon: add membw-bound bundle
Added memory bandwidth boundedness bundle, closely related to cache-hierarchy. This bundle works on ICX only, due to an ICX specific counter. Type: improvement Signed-off-by: Ray Kinsella <mdr@ashroe.eu> Change-Id: Id385bd5f4e645ac020774e311c623afb64b79b1e
Diffstat (limited to 'src/plugins/perfmon/CMakeLists.txt')
-rw-r--r--src/plugins/perfmon/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/perfmon/CMakeLists.txt b/src/plugins/perfmon/CMakeLists.txt
index af0bd3c3f51..6b8e7c80044 100644
--- a/src/plugins/perfmon/CMakeLists.txt
+++ b/src/plugins/perfmon/CMakeLists.txt
@@ -24,6 +24,7 @@ add_vpp_plugin(perfmon
table.c
intel/core.c
intel/uncore.c
+ intel/bundle/membw_bound.c
intel/bundle/inst_and_clock.c
intel/bundle/load_blocks.c
intel/bundle/mem_bw.c