summaryrefslogtreecommitdiffstats
path: root/src/plugins/perfmon/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Leaf <zachary.leaf@arm.com>2022-05-23 06:22:27 -0500
committerDamjan Marion <dmarion@0xa5.net>2022-07-12 15:29:23 +0000
commitc7d43a5eb19f2acab900274432cfd0e136d6cb44 (patch)
tree3ad3bd5191a1199430db40cec0b286ab531993be /src/plugins/perfmon/CMakeLists.txt
parent20ac58e5c5ef59bc860270037aa7a3b0966a4ec2 (diff)
perfmon: make less arch dependent
In preparation for enabling perfmon on Arm platforms, move some Intel /arch specific logic into the /intel directory and update the CMake to split the common code from arch specific files. Since the dispatch_wrapper code is very different on Arm/Intel, each arch can provide their own implementation + conduct any additional arch specific config e.g. on Intel, all indexes from the mmap pages are cached. The new method intel_config_dispatch_wrapper conducts this config and returns a pointer to the dispatch wrapper to use. Similarly, is_bundle_supported() looks very different on Arm/Intel, so each implementation is to provide their own arch specific checks. Two new callbacks/function ptrs are added in PERFMON_REGISTER_SOURCE to support this - .bundle_support and .config_dispatch_wrapper. Type: refactor Signed-off-by: Zachary Leaf <zachary.leaf@arm.com> Change-Id: Idd121ddcfd1cc80a57c949cecd64eb2db0ac8be3
Diffstat (limited to 'src/plugins/perfmon/CMakeLists.txt')
-rw-r--r--src/plugins/perfmon/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/src/plugins/perfmon/CMakeLists.txt b/src/plugins/perfmon/CMakeLists.txt
index c7b2a384cc2..59eddf01145 100644
--- a/src/plugins/perfmon/CMakeLists.txt
+++ b/src/plugins/perfmon/CMakeLists.txt
@@ -15,12 +15,8 @@ if(NOT CMAKE_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
return()
endif()
-add_vpp_plugin(perfmon
- SOURCES
- cli.c
- dispatch_wrapper.c
- linux.c
- perfmon.c
+list(APPEND ARCH_PMU_SOURCES
+ intel/dispatch_wrapper.c
intel/core.c
intel/uncore.c
intel/bundle/backend_bound_core.c
@@ -38,6 +34,14 @@ add_vpp_plugin(perfmon
intel/bundle/topdown_icelake.c
intel/bundle/topdown_metrics.c
intel/bundle/topdown_tremont.c
+)
+
+add_vpp_plugin(perfmon
+ SOURCES
+ cli.c
+ linux.c
+ perfmon.c
+ ${ARCH_PMU_SOURCES}
COMPONENT
vpp-plugin-devtools