summaryrefslogtreecommitdiffstats
path: root/src/plugins/perfmon/CMakeLists.txt
diff options
context:
space:
mode:
authorRay Kinsella <mdr@ashroe.eu>2021-11-02 13:44:13 +0000
committerDamjan Marion <dmarion@me.com>2021-11-02 22:25:40 +0000
commite15c999c304630aa8454032739bcb5e1406dccee (patch)
tree6e5992f59e8cc761af35a332b1caae5114e29464 /src/plugins/perfmon/CMakeLists.txt
parent63081acb3ff02d5d60e971943d03b8c9abeaae00 (diff)
perfmon: added bundle to measure pci bandwidth
Added an Intel Ice Lake specific bundles to measure pci bandwidth through the Intel IO PMU. The "PCI" bundle measures read/writes from pci devices. The "CPU" bundle measure read/writes from cpus to pci devices. Type: improvement Signed-off-by: Ray Kinsella <mdr@ashroe.eu> Change-Id: Id48cef5988113e8dc4690b97d22243311bfa7961
Diffstat (limited to 'src/plugins/perfmon/CMakeLists.txt')
-rw-r--r--src/plugins/perfmon/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/perfmon/CMakeLists.txt b/src/plugins/perfmon/CMakeLists.txt
index c587e6d503b..73598cf11a7 100644
--- a/src/plugins/perfmon/CMakeLists.txt
+++ b/src/plugins/perfmon/CMakeLists.txt
@@ -32,6 +32,7 @@ add_vpp_plugin(perfmon
intel/bundle/power_license.c
intel/bundle/topdown_metrics.c
intel/bundle/topdown_tremont.c
+ intel/bundle/iio_bw.c
COMPONENT
vpp-plugin-devtools