summaryrefslogtreecommitdiffstats
path: root/src/plugins/perfmon/CMakeLists.txt
diff options
context:
space:
mode:
authorRay Kinsella <mdr@ashroe.eu>2022-01-27 09:55:02 +0000
committerDamjan Marion <dmarion@me.com>2022-01-30 15:08:18 +0000
commit9d0c638b0fa28b9aebd9e3c0c0bdf98361d50a50 (patch)
tree58a696003ac68500a0824ad366a214d8305fbf53 /src/plugins/perfmon/CMakeLists.txt
parent7e8aeb876b3bf21075621e40c3c1aa2fa2874dfb (diff)
perfmon: topdown level 1 and 2 for icx
Topdown level 1 and 2 for Intel Ice Lake (ICX). Limiting topdown support to THREAD for the moment on Ice Lake, as NODE support is still unreliable. Also removing Topdown Level 1 from Sapphire Rapids onwards, as Topdown LeveL 2 also shows Level 1 on Sapphire, and it reduces the overall number of bundles. Type: improvement Signed-off-by: Ray Kinsella <mdr@ashroe.eu> Change-Id: Iaa68b711dc8b6fb1090880b411debadb3c37f8bc
Diffstat (limited to 'src/plugins/perfmon/CMakeLists.txt')
-rw-r--r--src/plugins/perfmon/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/perfmon/CMakeLists.txt b/src/plugins/perfmon/CMakeLists.txt
index 05c280f64ac..66894b1c5d0 100644
--- a/src/plugins/perfmon/CMakeLists.txt
+++ b/src/plugins/perfmon/CMakeLists.txt
@@ -32,6 +32,7 @@ add_vpp_plugin(perfmon
intel/bundle/branch_mispred.c
intel/bundle/power_license.c
intel/bundle/topdown_metrics.c
+ intel/bundle/topdown_icelake.c
intel/bundle/topdown_tremont.c
intel/bundle/frontend_bound_bw.c
intel/bundle/frontend_bound_lat.c