summaryrefslogtreecommitdiffstats
path: root/src/plugins/ping/CMakeLists.txt
diff options
context:
space:
mode:
authorMohsin Kazmi <sykazmi@cisco.com>2019-10-09 18:35:16 +0200
committerAndrew Yourtchenko <ayourtch@gmail.com>2019-10-27 10:06:30 +0000
commitf872cb0dad453e39dedb5586a8dbf566a5ea9295 (patch)
tree62c708d69e1c2972ab808dbe96d6b8457d639dbc /src/plugins/ping/CMakeLists.txt
parent13d35675f0a4daa7bbffa02a8cd4d22c8a2d6760 (diff)
ping: Move to plugin
Type: refactor Change-Id: I51d5bf54dfd408aa0c406cbdf0f4be10ef19d10d Signed-off-by: Mohsin Kazmi <sykazmi@cisco.com> (cherry picked from commit 26c7a4b0b6488423688f4a7f3c8aacf0d1b9c742)
Diffstat (limited to 'src/plugins/ping/CMakeLists.txt')
-rw-r--r--src/plugins/ping/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/plugins/ping/CMakeLists.txt b/src/plugins/ping/CMakeLists.txt
new file mode 100644
index 00000000000..2828f769fcc
--- /dev/null
+++ b/src/plugins/ping/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(ping
+ SOURCES
+ ping.c
+)