summaryrefslogtreecommitdiffstats
path: root/src/plugins/prom/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2022-01-31 16:16:13 -0800
committerFlorin Coras <fcoras@cisco.com>2022-02-02 17:04:46 -0800
commit7285be2aabf4ba9915a23085e63efb896c5a8896 (patch)
tree316597182679f013c76619e725aa5031263a039d /src/plugins/prom/CMakeLists.txt
parentc556fa49b462c6ebc206c9a5b3f6ff951d31f56a (diff)
prom: basic builtin prometheus stats exporter
This is a vpp builtin alternative, not a replacement, for the existing vpp_prometheus_exporter. The plugin works by registering with http_static as a url handler for stats.prom and handles requests by scraping the stats segment in the main thread. It will therefore consume vpp process cpu cycles. By default the plugin is disabled. To enable, first start the http static server an then use "prom enable" cli. Type: feature Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: If6888e965d1b2361f6a5546586068213d37079d1
Diffstat (limited to 'src/plugins/prom/CMakeLists.txt')
-rw-r--r--src/plugins/prom/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/plugins/prom/CMakeLists.txt b/src/plugins/prom/CMakeLists.txt
new file mode 100644
index 00000000000..6c1976c74f3
--- /dev/null
+++ b/src/plugins/prom/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (c) 2022 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(prom
+ SOURCES
+ prom.c
+ prom_cli.c
+
+ LINK_LIBRARIES
+ vppapiclient
+)