aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/srv6-un/CMakeLists.txt
diff options
context:
space:
mode:
authorPablo Camarillo <pcamaril@cisco.com>2019-12-18 17:13:13 +0000
committerNeale Ranns <nranns@cisco.com>2020-03-12 08:31:42 +0000
commit79bfd272546dd436a4d12f0ac98571194965dab0 (patch)
tree2610496dd4a94cf3c0d4a3da1b1e7cc5855d7c71 /src/plugins/srv6-un/CMakeLists.txt
parentf2833e42c1e3721ce06b0f510447d8a6dd3e5eb4 (diff)
sr: SRv6 uN behavior
Implements the uN behavior Type: feature Change-Id: Icb5efc560e09052cd183b468772cf7f799f81194 Signed-off-by: pcamaril <pcamaril@cisco.com>
Diffstat (limited to 'src/plugins/srv6-un/CMakeLists.txt')
-rw-r--r--src/plugins/srv6-un/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/plugins/srv6-un/CMakeLists.txt b/src/plugins/srv6-un/CMakeLists.txt
new file mode 100644
index 00000000000..9ecf0b3c8d0
--- /dev/null
+++ b/src/plugins/srv6-un/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(SRv6uN
+ SOURCES
+ un.c
+ node.c
+
+ INSTALL_HEADERS
+ un.h
+)