summaryrefslogtreecommitdiffstats
path: root/src/plugins/tlspicotls/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Zhang <yuwei1.zhang@intel.com>2021-06-07 23:19:33 +0800
committerDave Wallace <dwallacelf@gmail.com>2021-06-07 21:31:18 +0000
commitdd6fe0c5399e6f859e441686b703cdfa630204bd (patch)
treeffe30f7ad39a74ed788740b92a9ecd228b584036 /src/plugins/tlspicotls/CMakeLists.txt
parent53af06a214c15b9113df8ce66a6e95881370bb46 (diff)
tls: change picotls plugin crypto module to accommodate new version picotls
Type: fix Change-Id: I58931e235535be7d596ca578790f389b64a4fbd2 Signed-off-by: Simon Zhang <yuwei1.zhang@intel.com> (cherry picked from commit 778b3186fc911af2aabbbfbf56bc1df5e2373061)
Diffstat (limited to 'src/plugins/tlspicotls/CMakeLists.txt')
-rw-r--r--src/plugins/tlspicotls/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/tlspicotls/CMakeLists.txt b/src/plugins/tlspicotls/CMakeLists.txt
index 64f607117d3..f23ae6ccb8a 100644
--- a/src/plugins/tlspicotls/CMakeLists.txt
+++ b/src/plugins/tlspicotls/CMakeLists.txt
@@ -33,7 +33,7 @@ if(QUICLY_INCLUDE_DIR AND PICOTLS_INCLUDE_DIR AND PICOTLS_LINK_LIBRARIES)
pico_vpp_crypto.c
certs.c
- LINK_LIBRARIES ${PICOTLS_LINK_LIBRARIES}
+ LINK_LIBRARIES ${PICOTLS_LINK_LIBRARIES} ${OPENSSL_LIBRARIES}
)
message (STATUS "Found picotls in ${PICOTLS_INCLUDE_DIR} and ${PICOTLS_CORE_LIBRARY}")
else()