summaryrefslogtreecommitdiffstats
path: root/src/plugins/tracedump/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2020-07-07 17:33:38 -0400
committerDamjan Marion <dmarion@me.com>2020-07-16 21:39:50 +0000
commit65b65a4692c84462ecf500806795ea0350073e18 (patch)
tree7c502a71b7ab710d0b6bc1448c78f1ade0f4392b /src/plugins/tracedump/CMakeLists.txt
parentac0326fc5ae7ac4a8126bbc2f496a92fcfe4755e (diff)
misc: add tracedump API plugin
Type: feature Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I586547508003b95eaa74e18e4a5ac6f72986822c
Diffstat (limited to 'src/plugins/tracedump/CMakeLists.txt')
-rw-r--r--src/plugins/tracedump/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/plugins/tracedump/CMakeLists.txt b/src/plugins/tracedump/CMakeLists.txt
new file mode 100644
index 00000000000..d0491caf677
--- /dev/null
+++ b/src/plugins/tracedump/CMakeLists.txt
@@ -0,0 +1,28 @@
+
+# Copyright (c) <current-year> <your-organization>
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(tracedump
+ SOURCES
+ tracedump.c
+ tracedump.h
+
+ API_FILES
+ tracedump.api
+
+ API_TEST_SOURCES
+ tracedump_test.c
+)
+
+# API_TEST_SOURCES
+# tracedump_test.c