summaryrefslogtreecommitdiffstats
path: root/src/plugins/unittest/CMakeLists.txt
diff options
context:
space:
mode:
authorArtem Glazychev <artem.glazychev@xored.com>2020-08-31 15:42:40 +0700
committerDamjan Marion <dmarion@me.com>2020-09-01 19:12:22 +0000
commit1b6ed022e7a37fd1b35f2f9272cc4abc159d616d (patch)
treea04848d32c836df63e9f0d278eda793c5e2e929e /src/plugins/unittest/CMakeLists.txt
parent0a507d7cd5b0527af7ab971b80306a0d127ebb7c (diff)
crypto-openssl: add chacha20-poly1305 to crypto-openssl
Type: feature Signed-off-by: Artem Glazychev <artem.glazychev@xored.com> Change-Id: Iec28fb11b6edff1bee23117f56aa3a3e5729541a Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/plugins/unittest/CMakeLists.txt')
-rw-r--r--src/plugins/unittest/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/plugins/unittest/CMakeLists.txt b/src/plugins/unittest/CMakeLists.txt
index 3ea4752145b..18780b6a607 100644
--- a/src/plugins/unittest/CMakeLists.txt
+++ b/src/plugins/unittest/CMakeLists.txt
@@ -11,6 +11,11 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+set(chacha20_poly1305)
+if (OPENSSL_VERSION VERSION_GREATER_EQUAL 1.1.0)
+ set(chacha20_poly1305 crypto/chacha20_poly1305.c)
+endif()
+
add_vpp_plugin(unittest
SOURCES
api_fuzz_test.c
@@ -20,6 +25,7 @@ add_vpp_plugin(unittest
crypto/aes_cbc.c
crypto/aes_ctr.c
crypto/aes_gcm.c
+ ${chacha20_poly1305}
crypto/rfc2202_hmac_md5.c
crypto/rfc2202_hmac_sha1.c
crypto/rfc4231.c