summaryrefslogtreecommitdiffstats
path: root/src/plugins/unittest/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian Russell <brian@graphiant.com>2021-02-04 17:23:44 +0000
committerNeale Ranns <neale@graphiant.com>2021-02-10 16:39:22 +0000
commitf91ff5fc33eb1e5be5db06c3b4b5d1d4641d28e6 (patch)
treec546ce63e8daebd54ad73c87adf40f80c83b9de1 /src/plugins/unittest/CMakeLists.txt
parentb60620b9b5d5e07d2739a2d9ad2ac92286d80daa (diff)
tests: add policer test helper
Add a helper CLI to exercise a policer pre-configured by the test harness. The test harness will check the stats afterwards. Type: test Signed-off-by: Brian Russell <brian@graphiant.com> Change-Id: I913dda4a9f8179c1c6b3061a68164bf1e698a392
Diffstat (limited to 'src/plugins/unittest/CMakeLists.txt')
-rw-r--r--src/plugins/unittest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/unittest/CMakeLists.txt b/src/plugins/unittest/CMakeLists.txt
index 64a7706034b..b6322cddf09 100644
--- a/src/plugins/unittest/CMakeLists.txt
+++ b/src/plugins/unittest/CMakeLists.txt
@@ -38,6 +38,7 @@ add_vpp_plugin(unittest
mem_bulk_test.c
mfib_test.c
mpcap_node.c
+ policer_test.c
punt_test.c
rbtree_test.c
session_test.c