summaryrefslogtreecommitdiffstats
path: root/src/tools/appimage/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-03-24 16:25:03 -0400
committerDamjan Marion <dmarion@me.com>2019-03-28 08:18:57 +0000
commit0729f6481dd61d4f98ea534d651d7f1b9a7d5d4b (patch)
tree0e9ba08dc0ce4cda319957224f525eb0785eaf7a /src/tools/appimage/CMakeLists.txt
parent25edf14369b27ab3dfcda14b69dc53148c9ccf7e (diff)
AppImage packaging
Disabled by default. To kick the the tires: wget https://github.com/linuxdeploy/linuxdeploy/releases/download/continuous/linuxdeploy-x86_64.AppImage sudo mv linuxdeploy-x86_64.AppImage /usr/local/bin/linuxdeploy sudo chmod +x linuxdeploy-x86_64.AppImage Enable VPP_BUILD_APPIMAGE e.g. in ccmake make build | make build-release The vpp AppImage lands in .../install-xxx-native/VPP-x86_64.AppImage. To run it: ./VPP-x86_64.AppImage vpp unix interactive To run it (as root) and inhale the usual startup.conf: sudo ./VPP-x86_64.AppImage \${HERE}/bin/vpp -c \${HERE}/etc/vpp/startup.conf To run vppctl, or any of the usual vpp binaries: ./VPP-x86_64.AppImage vppctl [etc] Change-Id: Ide8cf4658cbb56f1d36a1ce7fc8f7338f8d38278 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'src/tools/appimage/CMakeLists.txt')
-rw-r--r--src/tools/appimage/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/tools/appimage/CMakeLists.txt b/src/tools/appimage/CMakeLists.txt
new file mode 100644
index 00000000000..1b83656dbf8
--- /dev/null
+++ b/src/tools/appimage/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+option(VPP_BUILD_APPIMAGE "Build VPP AppImage" OFF)
+if(VPP_BUILD_APPIMAGE)
+ install(FILES AppRun DESTINATION .
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE
+ GROUP_READ GROUP_WRITE GROUP_EXECUTE
+ WORLD_READ WORLD_EXECUTE)
+ install(FILES vpp.desktop DESTINATION .)
+ install(FILES vpp.png DESTINATION .)
+ install(FILES vpp.svg DESTINATION share/icons/hicolor/scalable/vpp.svg)
+ install(CODE "EXECUTE_PROCESS(COMMAND ln -s . ./usr
+ WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX})")
+ install(CODE "EXECUTE_PROCESS(
+ COMMAND linuxdeploy --appdir vpp --output appimage
+ WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX}/..)")
+endif()