summaryrefslogtreecommitdiffstats
path: root/src/tools/vppapigen/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Vinciguerra <pvinci@vinciconsulting.com>2018-09-12 13:40:13 -0700
committerDamjan Marion <dmarion@me.com>2018-09-13 00:32:35 +0000
commit9ce6a21aaa76cd40c95ebbcb5fc6e48a8f5dfdb9 (patch)
tree5656afec4a81b93dcda22b5af8b41c051f246bd8 /src/tools/vppapigen/CMakeLists.txt
parentb1232555e91b286feab5667b5a22f29aa8e96626 (diff)
Fix: vppapigen make build fails on fresh install
Steps to reproduce: vagrant@localhost:/vagrant$ build-root/vagrant/build.sh ... @@@@ Building vpp in /vagrant/build-root/build-vpp-native/vpp @@@@ [51/1169] Generating API header /vagrant/build-root/build-vpp-native/vpp/vlibmemory/memclnt.api.json FAILED: cd /vagrant/build-root/build-vpp-native/vpp/vlibmemory && mkdir -p /vagrant/build-root/build-vpp-native/vpp/vlibmemory && /vagrant/src/tools/vppapigen/vppapigen --includedir /vagrant/src --input /vagrant/src/vlibmemory/memclnt.api JSON --output /vagrant/build-root/build-vpp-native/vpp/vlibmemory/memclnt.api.json AttributeError: 'module' object has no attribute 'dumps' This seems to be due to JSON.py namespace colliding with the standard lib json.py Change-Id: If389e4e05ef0c166b0c2b3bef7ec0185298679a8 Signed-off-by: Paul Vinciguerra <pvinci@vinciconsulting.com>
Diffstat (limited to 'src/tools/vppapigen/CMakeLists.txt')
-rw-r--r--src/tools/vppapigen/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/tools/vppapigen/CMakeLists.txt b/src/tools/vppapigen/CMakeLists.txt
index 0d982fe29f8..ce25cb0c9e7 100644
--- a/src/tools/vppapigen/CMakeLists.txt
+++ b/src/tools/vppapigen/CMakeLists.txt
@@ -21,4 +21,4 @@ install(
COMPONENT vpp-dev
)
-install(FILES C.py JSON.py DESTINATION share/vpp COMPONENT vpp-dev)
+install(FILES vppapigen_c.py vppapigen_json.py DESTINATION share/vpp COMPONENT vpp-dev)