summaryrefslogtreecommitdiffstats
path: root/src/vat/CMakeLists.txt
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2020-09-15 10:53:34 +0200
committerDave Barach <openvpp@barachs.net>2020-09-18 15:24:52 +0000
commit3d81267945a732753b0dbd0a83a50ab0625b448a (patch)
treec00b5e6a5e798cbb29c9c450eb37d43f9303cb85 /src/vat/CMakeLists.txt
parent34262d4d56295b0872ad4e9a4a4791953f3fa444 (diff)
vat: add infrastructure to align vnet test code and plugin test code
Split vat/api_format.c also for VNET features. Use auto-generated VAT test code and support dynamic message ID allocation as for plugins. The arp and geneve features as Guinea pigs. Type: improvement Signed-off-by: Ole Troan <ot@cisco.com> Change-Id: I461591496766bdf10c5f950fd30f1a0ae05909da Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'src/vat/CMakeLists.txt')
-rw-r--r--src/vat/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vat/CMakeLists.txt b/src/vat/CMakeLists.txt
index 9d37b7ba83e..ed14e846625 100644
--- a/src/vat/CMakeLists.txt
+++ b/src/vat/CMakeLists.txt
@@ -32,6 +32,8 @@ add_vpp_executable(vpp_api_test ENABLE_EXPORTS
ip_types_api.c
ip_types.c
protocols.def
+ ../vnet/arp/arp_test.c
+ ../vnet/geneve/geneve_test.c
DEPENDS api_headers