summaryrefslogtreecommitdiffstats
path: root/src/vcl/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2023-02-02 12:56:16 -0800
committerDave Wallace <dwallacelf@gmail.com>2023-02-08 02:19:58 +0000
commit90c9bb871f9b252e15dde0cb0a20e27498ade871 (patch)
treeec26c5f3e997fdd339bb90bee1f5d12a6cf162bf /src/vcl/CMakeLists.txt
parentc6fe2c3053b7534e38fbf04d4442fc3f166a55c0 (diff)
vcl: better handlig of ldp apis that rely on gnu source
Control use of apis that rely on _GNU_SOURCE being defined with compile time macro. Also fixes sendmmsg and recvmmsg which were not probably wrapped. Type: improvement Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: I207de23210d4b9dc960bb4289159502760c5614d (cherry picked from commit 3684794336602435b91b91a1dc5bd9401a974432)
Diffstat (limited to 'src/vcl/CMakeLists.txt')
-rw-r--r--src/vcl/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/vcl/CMakeLists.txt b/src/vcl/CMakeLists.txt
index e6d8f98ffed..610b422d113 100644
--- a/src/vcl/CMakeLists.txt
+++ b/src/vcl/CMakeLists.txt
@@ -30,6 +30,11 @@ add_vpp_library(vppcom
api_headers
)
+option(LDP_HAS_GNU_SOURCE "LDP configured to use _GNU_SOURCE" ON)
+if (LDP_HAS_GNU_SOURCE)
+ add_compile_definitions(HAVE_GNU_SOURCE)
+endif(LDP_HAS_GNU_SOURCE)
+
add_vpp_library(vcl_ldpreload
SOURCES
ldp_socket_wrapper.c