aboutsummaryrefslogtreecommitdiffstats
path: root/src/vlib/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2018-09-28 15:16:14 +0000
committerDamjan Marion <dmarion@me.com>2019-03-28 20:51:32 +0000
commit76b5649d074ab198cbf5737ac76d21649a61bffd (patch)
treebb856c9638cb63ead6c00837daad01373551b4e1 /src/vlib/CMakeLists.txt
parent1f4e1cbf576fc6ab4e871ba0603028112074b43b (diff)
Punt Infra
A punt/exception path that provides: 1) clients that use the infra 2) clients can create punt reasons 3) clients can register to recieve packets that are punted for a given reason to be sent to the desired node. 4) nodes which punt packets fill in the {reason,protocol} of the buffere (in the meta-data) and send to the new node "punt-dispatch" 5) punt-dispatch sends packets to the registered nodes or drops Change-Id: Ia4f144337f1387cbe585b4f375d0842aefffcde5 Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vlib/CMakeLists.txt')
-rw-r--r--src/vlib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/vlib/CMakeLists.txt b/src/vlib/CMakeLists.txt
index ff64baea980..acd66359f9b 100644
--- a/src/vlib/CMakeLists.txt
+++ b/src/vlib/CMakeLists.txt
@@ -63,6 +63,8 @@ add_vpp_library(vlib
node_format.c
pci/pci.c
physmem.c
+ punt.c
+ punt_node.c
threads.c
threads_cli.c
trace.c
@@ -77,6 +79,7 @@ add_vpp_library(vlib
MULTIARCH_SOURCES
drop.c
+ punt_node.c
INSTALL_HEADERS
buffer_funcs.h
@@ -102,6 +105,7 @@ add_vpp_library(vlib
pci/pci.h
physmem_funcs.h
physmem.h
+ punt.h
threads.h
trace_funcs.h
trace.h