summaryrefslogtreecommitdiffstats
path: root/src/vlib/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-03-01 15:53:11 +0000
committerDamjan Marion <dmarion@me.com>2019-03-13 14:00:30 +0000
commit22e1f1d136790f1ee974ace7e299492582921b66 (patch)
treea5183a7dbc5d14439ee03b7764be8220c31fd315 /src/vlib/CMakeLists.txt
parentaee73648cf524f2627a8680ca26a68d6a2c8e164 (diff)
Move the punt/drop nodes into vlib
The core VLIB library now has a means to dispoe of buffers. the vlib punt/drop node counts node errors. the vnet punt/drop node counts interface errors. speed up both nodes with the usual reciepe. before: error-drop 8.33e1 after: drop 4.51e1 error-drop 6.81e0 Change-Id: If2e919458a3f2e9d71dbf9c6f1352dafb186a05b Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vlib/CMakeLists.txt')
-rw-r--r--src/vlib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/vlib/CMakeLists.txt b/src/vlib/CMakeLists.txt
index 86fc965ba97..ff64baea980 100644
--- a/src/vlib/CMakeLists.txt
+++ b/src/vlib/CMakeLists.txt
@@ -49,6 +49,7 @@ add_vpp_library(vlib
buffer.c
cli.c
counter.c
+ drop.c
error.c
format.c
i2c.c
@@ -74,6 +75,9 @@ add_vpp_library(vlib
vmbus/vmbus.c
${VMBUS_SOURCE}
+ MULTIARCH_SOURCES
+ drop.c
+
INSTALL_HEADERS
buffer_funcs.h
buffer.h