aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <neale.ranns@cisco.com>2018-08-29 06:37:18 -0700
committerDave Barach <openvpp@barachs.net>2018-08-31 11:58:46 +0000
commitde5b08fb302e84142e4ba0cf0cbed4e740e4165c (patch)
tree7e98b2a17dcb1c511f7603bf5b2d6206326cfe47 /src/vnet/CMakeLists.txt
parent45478933b21cf1bce028b757e1358936dd08380b (diff)
Introduce a mac_address_t on the API and in VPP
Change-Id: I05d6c2cb5d34de469eb050e4ee10dc6b954c986d Signed-off-by: Neale Ranns <neale.ranns@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index a10ec821e9a..61945a41867 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -109,9 +109,11 @@ list(APPEND VNET_API_FILES cop/cop.api)
# Layer 2 protocol: Ethernet
##############################################################################
list(APPEND VNET_SOURCES
+ ethernet/ethernet_types_api.c
ethernet/format.c
ethernet/init.c
ethernet/interface.c
+ ethernet/mac_address.c
ethernet/node.c
ethernet/pg.c
ethernet/sfp.c