aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorBenoît Ganne <bganne@cisco.com>2019-05-17 14:24:17 +0200
committerDave Barach <openvpp@barachs.net>2019-05-18 19:01:51 +0000
commit09267f705f408c061e03d07a559efba661900f2d (patch)
treeaf20b028831a2dedcf4b343a60aee50e64d16258 /src/vnet/CMakeLists.txt
parent35465dc0be7d4e607f5bc3d094e2e845e61cea70 (diff)
api: export ip_types.api for out-of-tree plugins
Out-of-tree plugins can refer to IP types in their API. The .api and associated headers must be exported. Change-Id: I75004343b040defd9eebac6a8a95c2ecf3c8079a Signed-off-by: Benoît Ganne <bganne@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 89d46a14b82..1940abe03c2 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -58,6 +58,7 @@ list(APPEND VNET_HEADERS
interface_funcs.h
ip/ip4_to_ip6.h
ip/ip6_to_ip4.h
+ ip/ip_types_api.h
l3_types.h
plugin/plugin.h
pipeline.h
@@ -68,7 +69,10 @@ list(APPEND VNET_HEADERS
util/refcount.h
)
-list(APPEND VNET_API_FILES interface.api)
+list(APPEND VNET_API_FILES
+ interface.api
+ ip/ip_types.api
+)
##############################################################################
# Policer infra