aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-02-01 03:31:24 -0800
committerFlorin Coras <florin.coras@gmail.com>2019-02-01 23:39:13 +0000
commit999c8ee6d6f1c07ba7877fb3f9aa66a90774aacc (patch)
tree3bc5d7e98fc02a3c491fe72286ce330c70446aea /src/vnet/CMakeLists.txt
parente7ada526ac1577179c03ba1a4146dbbf3cc431aa (diff)
IPSEC: minor refactor
No function change. Only breaking the monster ipsec.[hc] into smaller constituent parts Change-Id: I3fd4d2d041673db5865d46a4002f6bd383f378af Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index a595df25344..bc581620488 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -480,6 +480,9 @@ list(APPEND VNET_SOURCES
ipsec/ipsec_input.c
ipsec/ipsec_if.c
ipsec/ipsec_if_in.c
+ ipsec/ipsec_sa.c
+ ipsec/ipsec_spd.c
+ ipsec/ipsec_spd_policy.c
ipsec/esp_format.c
ipsec/esp_encrypt.c
ipsec/esp_decrypt.c