summaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2020-04-13 16:44:09 -0400
committerDave Barach <dave@barachs.net>2020-04-13 16:44:42 -0400
commitfd0834262c517ea3a420fdba05fb95bc4141762b (patch)
treed4c5b72fd2734cc81120c7f4a1f6b98f9f06560e /src/vnet/CMakeLists.txt
parent5e62c84bb7058b58d9f0fa3b5eff9af93c073274 (diff)
dhcp: fix unicast pkts, clean up state machine
Nominally a bug-fix cherry-pick, but completely manual. Closer to a full feature backport minus binary api changes. Send dhcp unicast packets to ip4-lookup. Otherwise, these packets won't reach a dhcp server on a different subnet. Do an immediate client scan after processing wakeup events. Calculate the next process wakeup time by scanning all clients. Increase maximum (idle, no-clients-configured) timeout to 1000 seconds. Reduce log spew. Type: fix Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I3d10cd4c353298ed0b19e7e30887dc1d8d07b19e (cherry picked from commit c54162981cdd41d65ed283df36955007552ddffe)
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 4b7972dd960..d237867fc1b 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -890,6 +890,7 @@ list(APPEND VNET_API_FILES lisp-gpe/lisp_gpe.api)
##############################################################################
list(APPEND VNET_SOURCES
dhcp/client.c
+ dhcp/dhcp4_packet.c
dhcp/dhcp_client_detect.c
dhcp/dhcp6_client_common_dp.c
dhcp/dhcp6_pd_client_dp.c