summaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2018-09-09 04:41:02 -0400
committerDamjan Marion <dmarion@me.com>2018-09-11 17:24:07 +0000
commiteb1525f1060569cc3dc03aca7696ce05e1401a09 (patch)
treeb9fffe456cf81f250c103535215db00645fe9d0e /src/vnet/CMakeLists.txt
parentc0a93143412b4be7bba087bf633855aeeaee7c56 (diff)
L2-learn; cache prefetch fix
the header is written (STORE) the data is only read (LOAD) Change-Id: Ia3ac0c81224a0db736c329ed3e2e55b7417f08a0 Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 29f5fef8626..549b3ac3c4a 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -120,7 +120,7 @@ list(APPEND VNET_SOURCES
ethernet/p2p_ethernet_api.c
)
-list(APPEND VNET_MULTIARCH_SOURCES ethernet/node.c l2/l2_output.c)
+list(APPEND VNET_MULTIARCH_SOURCES ethernet/node.c)
list(APPEND VNET_HEADERS
ethernet/error.def
@@ -158,6 +158,8 @@ list(APPEND VNET_SOURCES
l2/l2_xcrw.c
)
+list(APPEND VNET_MULTIARCH_SOURCES l2/l2_output.c l2/l2_learn.c)
+
list(APPEND VNET_HEADERS
l2/feat_bitmap.h
l2/l2_input.h