summaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2021-10-27 15:17:47 -0700
committerDave Barach <openvpp@barachs.net>2021-10-31 15:18:58 +0000
commit943a4b0750a2bee04788cb153ca56fa07d5005d7 (patch)
tree2e67aa82cdabf74768b3edcf4c8961964e5b3f8c /src/vnet/CMakeLists.txt
parentd9fc708ee0c8c42fa09dda5d29e9cb0f985558dc (diff)
interface: handoff refactor and optimizations
- move existing ethernet hash functions to hash infra (no l4 awareness) - refactor code to use hash infra and add apis to request l4 aware hashing functions - hashing functions per interface - code cleanup Type: improvement Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: Ia9f44db98d83f0f027aeb37718585a2e10ffd2c6
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index cff723937b2..395f958185e 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -56,7 +56,6 @@ list(APPEND VNET_HEADERS
devices/netlink.h
flow/flow.h
global_funcs.h
- handoff.h
interface/rx_queue_funcs.h
interface/tx_queue_funcs.h
interface.h
@@ -889,6 +888,7 @@ list(APPEND VNET_SOURCES
hash/hash.c
hash/cli.c
hash/crc32_5tuple.c
+ hash/crc32_handoff_eth.c
)
list(APPEND VNET_HEADERS