summaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-05-15 02:13:37 -0700
committerOle Trøan <otroan@employees.org>2019-05-28 13:30:44 +0000
commit50f0ac0f097e5495da1f2b1816106e3d420ff34b (patch)
treed10ae0385fc10b7da97b2a24f8dea3882f6d702d /src/vnet/CMakeLists.txt
parent9080096f7c548415fc4d5354c7e582a3eda1a5ed (diff)
Punt: socket register for exception dispatched/punted packets based on reason
- add to the Punt API to allow different descriptions of the desired packets: UDP or exceptions - move the punt nodes into punt_node.c - improve tests (test that the correct packets are punted to the registered socket) Change-Id: I1a133dec88106874993cba1f5a439cd26b2fef72 Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 1940abe03c2..dcbdb73d841 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -449,6 +449,7 @@ list(APPEND VNET_SOURCES
ip/ping.c
ip/punt_api.c
ip/punt.c
+ ip/punt_node.c
)
list(APPEND VNET_MULTIARCH_SOURCES
@@ -459,7 +460,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
ip/ip6_reassembly.c
ip/ip6_input.c
ip/ip6_punt_drop.c
- ip/punt.c
+ ip/punt_node.c
ip/ip_in_out_acl.c
)